Compatibility of the S-Bus OPC-Server with PG5 1.2 and PG5 1.3

FAQ #100240

If you want to use the S-Bus OPC-Server and PG5 on the same PC then you have to make attention to use the correct version of the S-Bus OPC-Server which fit with the corresponding version of the scommdll.

The SBC communication driver (scommdll) for PG5 1.2 and PG5 1.3 internally don’t have the same structure.
Since the S-Bus OPC-Sever uses the scommdll to communicate with the PCD’s we have to adapt the S-Bus OPC-Server depending oft the scommdll which was used to communicate.
If you want to use on the same PC the S-Bus OPC-Server and PG5 then you have to make attention to use the correct version of the S-Bus OPC-Server and the scommdll.

If it's necessary to access from the same PC simultaneously the PCD's with the S-Bus OPC-Server and PG5 then you have to use for PG5 and the S-Bus OPC-Server the same scommdll. That means that you have to use a version of the S-Bus OPC-Server which fit with the version of PG5.


Mismatching the versions of the S-Bus OPC-Server and the scommdll will cause a bad functionality of the S-Bus OPC-Server.

Version of PG5Scomm.dll version of PG5/S-Bus OPC-ServerNeeded Version of S-Bus OPC-Server
1.2.xxx1.2.xxx.xLess or equal then version 2.02.09.01
1.3.xxx1.3.xxx.xEqual or greater then version 2.02.10.15

Nerveless it’ possible to run for example the S-Bus OPC-Server v 2.02.09.01 on a PC where PG5 V1.3 was installed.
In this case the S-Bus OPC-Server doesn’t have to use the scommdll of PG5 V1.3 but he has to use the scommdll (V 1.2) stored on the S-Bus OPC-Server installation package.
If PG5 and the OPC-Server use two different version of the scommdll then it’s not possible to go online with a PCD simultaneously with both tools.
To install the scommdll which is stored on the S-Bus OPC-Server installation package, during the installation of the S-Bus OPC-Server you have to select “Install SBC communication driver”.

image

 

Related Files:

Categories

Software (except PG5) / OPC Server

PG5 1.x

Software (except PG5) / SCOMM

Last update: 25.05.2015 09:35

First release: 14.10.2004 10:53

Views: 2964

The requested software / document is no longer marketed by Saia-Burgess Controls AG and without technical support. It is an older software version which can be operated only on certain now no longer commercially available products.

Download