Why are the alarms not displayed in the "Web Alarming" list?

FAQ #100749

All the application is working correct with no error indication, nevertheless, the Alarms aren't displayed in the Web Alarming list. The list remains blank and no columns are visible as on the picture below.

 

Symptom
All the application is working correct with no error indication, nevertheless, the Alarms aren't displayed in the Web Alarming list from the Alarming Macro. When displayed on a PC with the Internet Explorer or Firefox, the list remains blank and no columns are visible as on the picture below.
image
When displayed on a VGA MB Panel with firmware 1.12.05, the error message "Error -51: .../alarm.exe?-6&sta failed!" is displayed in the Message Box teq view. 

Reason
This phenomenon can be caused by an incorrect format configuration of the PPO "A.Alarm.ThisAlarmList.MyName", "A.Alarm.AllgemeineAlarmliste.MyName" (or however your Alarmlist is called). This PPO must have the format "STRING" and unfortunately not all S-WebEditor versions do automatically define this format.
image
If the format is empty or not equal "STRING", the alarmlist will not work correctly.

Solution
Define the format "STRING" for the AlarmList PPO and rebuild the S-WebEditor project. Once the S-WebEditor project is rebuilt, execute a "Rebuild All..." in the PG5 Project manager and download the project (the *.tcr file must be updated on the PCD; this file is concerned by the modification of the format).

 

Categories

Local FAQ Deutschland / Fupla

Web Editor5

PCD7 / D4xx (MB Panel)

PG5 2.0 / Fupla

Last update: 31.05.2015 23:34

First release: 17.08.2007 17:01

Views: 7031

The requested software / document is no longer marketed by Saia-Burgess Controls AG and without technical support. It is an older software version which can be operated only on certain now no longer commercially available products.

Download