Product Index

  • Welcome to the support site

    If you know our products and are looking for technical information you are at the right place here.

     

    If you want to get an overview about our company, news and events please refer to www.saia-pcd.com.

     

     

  • System Catalogue 2016/2017

    A quick way to get an overview about our product range is to consult our system catalogue PLC, DDC, HMI, Web& IT

    • [17.7MB]
      [17.7MB]
      [17.0MB]
      [17.6MB]

Security Upgrade for PCD Controllers

New Firmwareversions offering improvements in IT-Security for PCD Controllers are ready to download. >> More Infos

Connection of PCD controllers directly to the Internet

Reduce the risk of potential intruders in automation systems. Take appropriate protective measures in your PCD control. >>More Infos

Last changes to this site

COSinus Firmware 1.24.09 for PCD2.M5440 and PCD2.M5540 is available on the support homepage

Thursday, 18. September 2014

COSinus Firmware 1.24.09 for PCD2.M5440 and PCD2.M5540 is available on the support homepage.

The firmware 1.24.09 can be used only on PCD2.M5xx0 with 8 MB onboard firmware memory.
The table on the section "firmware for Saia PCD COSinus" on our support homepage does show the hardware dependencies in relation with the COSinus firmware versions.

Do use at least the PG5 firmware downloader version 2.1.311 or newer (included in PG5 patch 2.1.311 or newer) to prevent the loading of the FW 1.24.xx to a not compatible PCD.


COSinus Firmware 1.24.05 is available on the support homepage

Tuesday, 26. August 2014

COSinus Firmware 1.24.05 for PCD1.M0/M2, PCD2.M5, PCD3.Mxxx0, PCD3.Mxx60,  PCD7.D4xxxT5F BACnet and LonIP is available on the support homepage.

The firmware 1.24.05 can be used only on PCD’s with 8 MB onboard firmware memory.
The table on the section "firmware for Saia PCD COSinus" on our support homepage does show the hardware dependencies in relation with the COSinus firmware versions.

Do use at least the PG5 firmware downloader version 2.1.311 or newer (included in PG5 patch 2.1.311 or newer) to prevent the loading of the FW 1.24.xx to a not compatible PCD.


Patch PG5 2.1.311 is available on the support homepage as well in the SBC PG5 update manager

Tuesday, 03. June 2014

The patch PG5 2.1.311 does include the ‘Firmware Downloader’ version 2.1.311.
The firmware 1.24.xx can be installed only on the last hardware version of PCD2 and PCD3 platform.
The new version of the ‘Firmware Downloader’ checks the hardware version of the connected PCD and disables the download of a new firmware on old PCD hardware version.

Link to the patch PG5 2.1.311


PG5 2.1.310 is available on the support homepage as well in the SBC PG5 update manager

Wednesday, 23. April 2014

PG5 2.1.310 can be downloaded from the support homepage as well in the SBC PG5 update manager.
Information's about the modification are available on the support homepage.


Certified BACnet FW and certificates

Monday, 07. April 2014

The new WSPCert certified BACnet FW 1.22.29 and the corresponding certificates are available here.


The requested software / document is no longer marketed by Saia-Burgess Controls AG and without technical support. It is an older software version which can be operated only on certain now no longer commercially available products.

Download