Product Index   PG5 Controls Suite   PG5 2.3 Suite

  • PG5 2.3

  • PG5 Suite V2.3.119

Documentation

What's new in PG5 2.3

Flyer 2.3.113 / 2.3.119 What's new in PG5 2.3

2.3.11x .pdf 1.58 MB Download
2.3.11x .pdf 1.58 MB Download
2.3.11x .pdf 1.66 MB Download

PG5 2.2/2.3 User's guide

Manual 26-732 PG5 2.2/2.3 User's guide

V12 .pdf 8.91 MB Download
V12 .pdf 6.34 MB Download
V12 .pdf 9.46 MB Download
V12 .pdf 10.61 MB Download

System Catalogue : Software

Extract PP26-215_B0100 System Catalogue : Software

System Catalogue
Software for Windows PCs

ENG15b .pdf 7.72 MB Download
FRA15b .pdf 7.72 MB Download
GER15b .pdf 7.72 MB Download
ITA15b .pdf 7.71 MB Download

System Catalogue : Controls Suite PG5 - Core

Extract PP26-215_B0111 System Catalogue : Controls Suite PG5 - Core

Extract from the System Catalogue P+P26/215

ENG14 .pdf 8.90 MB Download
FRA14 .pdf 9.20 MB Download
GER14 .pdf 8.95 MB Download
ITA14 .pdf 9.19 MB Download

Additional Documentation (Manuals, Workshops) can be found on the Controls Suite DVD

PG5 Suite for Windows 7 SP1 and Windows 10

This version allows to use the full functionality of PG5 2.3 for 90 days.
Link to an overview of the new features of PG5 2.3.

PG5 V2.3.119 installer for 32-bit and 64-bit Windows

Software V2.3.119 PG5 V2.3.119 installer for 32-bit and 64-bit Windows

V2.3.119 463 MB Download

Full PG5 V2.3.119 package (complete DVD content)

Software V2.3.119 full Full PG5 V2.3.119 package (complete DVD content)

V2.3.119 full 1024 MB Download

Installation Guide PG5 V 2.3

Manual PG5 2.3 Installation Guide PG5 V 2.3

2.3 .pdf 1.09 MB Download
2.3 .pdf 1.06 MB Download
2.3 .pdf 1.08 MB Download
2.3 .pdf 1.02 MB Download

Microsoft .Net 4.5.2 Framework must be installed on the PC.
The Microsoft .Net Framework 4.5.2 can be found in the above DVD Image in the folder "Windows\DotNet\NDP452-KB2901907-x86-x64-AllOS-ENU.exe"

 

 

  • Firmware requirement for full PG5 functionality

It's important to use the latest PCD COSinus 1.22 xx (or higher) firmware versions for full compatibility with PG5 2.2

Remarks

  • Usage of PG5 2.3.1xx
    PG5 2.3.1xx and PG5 2.2.xxx can be in installed in parallel on the same PC.
    By default, PG5 2.3.1xx will use the projects and F-Box libraries in the directory:
    C:\Users\<user name>\SBC\PG5 V2.3.1xx\
    And PG5 2.2.1xx will use the projects and F-Box libraries in the directory:
    C:\Users\Public\SBC\PG5 V2.2.1xx\
    And PG5 2.2.2xx does use the directory:
    C:\Users\Public\SBC\PG5 V2.2.2xx\
    Means that if a PG5 2.2.1xx or PG5 2.2.2xx project is transferred to PG5 2.3.1xx, the project must first be imported into PG5 2.3.1xx.
    Custom F-Box libraries from PG5 2.2.1xx/PG5 2.2.2xx must be installed again in PG5 2.3.1xx.
  • BACnet revision 14:
    BACnet revision 14 requires a PCD and BACnet FW >= 1.28.xx.
    The PCD and BACnet FW >= 1.28.xx does not support BACnet revision 9.
    BACnet revision 9 requires a PCD and BACnet firmware <= 1.26.xx.
    The PCD and BACnet firmware <= 1.26.xx does not support BACnet revision 14.
  • Use of PG5 2.3.100 or newer
    Windows Start menu

    Since PG5 2.2.130, in the Windows Start menu, the Saia PG5 applications are accessible directly under the folder ‘PG5 Suite V2.2.130’ and no more under the folder ‘Saia Burgess Controls’.
    This change has been made in order to be compatible with the Windows 10 start menu that’s accept only one level of folder
  • Use of PG5 2.3.100 or newer
    Since the version 2.1.300, the PG5 folders structure on the PC has changed compared to previous PG5 version and therefore it's necessary to:
    - Re-register PG5 2.3.1xx
      (the existing registration.key from PG5 2.1/PG5 2.2 can be re-used but it's necessary to use a new
       user.key; the user.key of PG5 2.1 or PG5 2.2 does not work on PG5 2.3)

Known restrictions

  • PG5 2.3.113, Easy Update Tool:
    The Easy Update Tool is not part of the PG5 v2.3.
    The brand new tool is still under development and will be available in the PG5 2.3 Service Pack1.
    The tool contains an installer and a wizard.
    Wizard: The project developer will get a wizard to configure and generate only one single backup file containing the Firmware, the PG5 program and the complete Web Editor 8 project.
    Installer tool: The Easy Update tool is primarily designed for end customer who will be able to download a new project or update an existing project on site. The tool does perform an automatic reboot of the PCD’s and programmable MB-Panels after the loading of the file.
  • PG5 2.3.113, Graftec Editor:
    The Graftec Editor does not support the complete range of functions as is usual with PG5.
    The missing features are listed below:
    - Graftec communication with Fupla isn’t implemented yet. It’s under development
    - Graftec symbols are not visible in Fupla editor yet. The symbol integration is under development.
    The missing functions will be available in the PG5 2.3 Service Pack 1.
  • PG5 2.3.113, HTML5 on IPad:
    The IPad can run into performance issues.
    It takes a long time to load a new page if you click on a button that has a view jump.
    Corrections are still being implemented and will be available in the PG5 2.3 Service Pack 1.
  • PG5 2.3.113, Project Generator:
    The Project Generator Wizard is disabled for the first PG5 v2.3 version due to an issue of the project creation. The Project Generator will be available in the Service Pack version again.
  • PG5 2.3.113, Web-Editor8:
    Referenced variables aren't available in variable selection dialogs before manually refreshing the variable table(s). In case of a new project, this even prevents the variable selection dialog of properties or function-/condition-parameters from showing because there's no existing variables yet.
  • PG5 2.3.113, Web-Editor8:
    HTML5 Browser Compatibilty:
    Edge, Safari, Chrome and Firefox supports HTML5.
    IE: HTML5 is not supported.
  • PG5 2.3.113, Web-Editor5 and Web-Builder:
    Web-Editor5 and the stand alone Web-Builder are no more installed per default on PG5 2.3.
    If needed it's possible to install the Web-Editor5 manuelly. (Parts of PG5 2.3)
    During the installation of Web-Editor5 also the stand alone Web-Builder will be installed.

Good to know

  • PG5 Licensing
    In order to use PG5 version 2.3, a new ‘USER.KEY’ file is needed. The key file from V2.2, V2.1, V2.0 or V1.4 cannot be used. However, you can run V2.3 as a Demonstration version for 90 days without a key file. The ‘USER.KEY’ file is available from your Saia representative.
    This key file registers your Company and enables the features of the PG5 which are needed.
    PG5 user registration
    Since PG5 V2.1 we have introduced registration for individual PG5 developers, in addition to the existing company registration. The file name of the user registration file is 'REGISTRATION.KEY'
    It's possible to use the same 'REGISTRATION.KEY' from PG5 2.1 and PG5 2.2 also in PG5 2.3
    When the PG5 first opens, you will be asked to register yourself as a PG5 User.
    A PG5 user is entitled to free software updates, free technical support, and other benefits.
    Demonstration version must complete the PG5 user registration before the PG5 can be used.
    It means that PG5 V2.3 with a demo key will not run without having a valid user registration.
    Licensed users, with a valid ‘USER.KEY’ file, can skip the developer registration indefinitely.
  • Compatibility with previous versions
    It's possible to install in parallel PG5 2.3, PG5 2.2, PG5 2.1, PG5 2.0 and PG5 1.4 on the same PC
    Compatibility with PG5 projects version 2.0, 2.1 and 2.2:
    PG5 V2.0 2.1 and 2.2 projects are upward compatible with PG5 V2.3, but not back again.
    Once a project has been opened with PG5 V2.3, it is not possible to open it again with the previous versions.
    We recommend to use different project directories for each PG5 version so they do not get mixed up.
    Projects made with the PG5 2.0, 2.1 and 2.2 must be imported or restored in PG5 Version 2.3. This makes a new copy of the project and converts the files to the new format. The original project stays unchanged Compatibility with the user FBoxes written for PG5 2.0, 2.1 and 2.2.
    The FBox libraries written for PG5 2.1 and 2.2 are fully compatible with PG5 Version 2.3.
    There is no change concerning the FBox definition files, the source files and the help files.
    Compatibility with PG5 projects version 1.4
    PG5 V1.4 projects are upward compatible with PG5 V2.3, but not back again. Once a project has been opened with the new PG5 V2.3, it is not possible to open it again with the previous versions (since files are converted to the new format). We recommend to use different project directories for each PG5 version so they do not get mixed up. Projects made with the PG5 1.4 must be imported or restored in PG5 Version 2.3. This makes a new copy of the project and converts the files to the new format. The original project stays unchanged.

    Compatibility with the user FBoxes written for PG5 1.4 or previous versions

    The FBox libraries written for PG5 1.4 or old versions have to be update to be used under PG5 V2.3

    This update can be supported by the library author or the end user itself.

 

The S-Web editor 5 and S-Web editor 8 which are supplied together with PG5 2.2.100 does contain the new java applet 5_15_03 from 03.02.2016. (Version 5.15.0321)
This java applet does solves the problems which are described on the FAQ 101811 and FAQ 101793

 

Supported operating systems are

  • Microsoft Windows 7 SP 1 (32 or 64 bit version)
  • Microsoft Windows 10

Windows 95, 98, ME, NT, 2000, Vista and XP are no longer supported by PG5 2.2 or later.

 

A short list of the advantages of PG5 2.0/PG5 2.1/PG5 2.2/PG5 2.3 and when to work with which PG5 version can be found in FAQ 101282.

 

For best performance, we recommend installing PG5 2.3 on a PC with a multi-core CPU running at a minimum of 2GHz with a minimum of 4GB RAM (8GB or more is recommended). The installation package requires about 700MB of free space on your hard disk.

Products not supported by PG5 2.3

The following products and protocols are not supported by PG5 2.3:

  • PCD4 and PCD6
  • S-Bus RIO (used with PCD1.T240)
  • Profibus FMS

For existing projects which are running with these controllers or protocols we recommend using PG5 1.4.300.

PG5 2.3

  • Why the PG5 2.1, 2.2 or 2.3 update manger application is no more working and it’s not possible to download files from PG5 update manager server? (FAQ #102020)
  • Shall I use PG5 2.3, PG5 2.2, 2.1, 2.0 or PG5 1.4 for my next project? (FAQ #102018)
  • Shall I use PG5 2.3, PG5 2.2, 2.1, 2.0 or PG5 1.4 for my next project? (FAQ #101282)

PG5 2.3 / Fupla

  • Why the PG5 2.1, 2.2 or 2.3 update manger application is no more working and it’s not possible to download files from PG5 update manager server? (FAQ #102020)
  • Shall I use PG5 2.3, PG5 2.2, 2.1, 2.0 or PG5 1.4 for my next project? (FAQ #102018)
  • Shall I use PG5 2.3, PG5 2.2, 2.1, 2.0 or PG5 1.4 for my next project? (FAQ #101282)

The requested software / document is no longer marketed by Saia-Burgess Controls AG and without technical support. It is an older software version which can be operated only on certain now no longer commercially available products.

Download