"HMI: Wrong library version: xxxxxx" with a DDC Suite project

FAQ #100660

This error occurs if the installed HMI Editor version does not match the current projects HMI library version. This often happens during the rebuild of a DDC Suite project which was originally created with an older PG5 or HMI Editor version.

 

Reason

 

As already explained in FAQ #100351, this error is caused by an incompatibility between the actually installed HMI Editor and the HMI library version of the current project. While it may help to deactivate the override libraries in the project's software settings, this approach is not suitable for DDC Suite projects, since these projects heavily depend on override libraries!

Solution

Copy all files shmi*.* from the default library folder (e.g. C:\Program Files\Saia-Burgess\PG5 1_4\Libs\Std) to the respective override library folder. The actual path can be looked up on the "Directories" tab within the Software Settings dialog. After copying all the shmi*.* files and doing a rebuild in PG5, the error message should be gone.

Please note: These steps are necessary for each and every single DDC Suite project, because with DDC Suite all FBoxes and further libraries are stored locally within the project!

 

Categories

Local FAQ Deutschland / HMI Editor

Last update: 31.05.2015 02:14

First release: 17.01.2007 13:33

Views: 1158

The requested software / document is no longer marketed by Saia-Burgess Controls AG and without technical support. It is an older software version which can be operated only on certain now no longer commercially available products.

Download