Product Index

  • Welcome to the support site

    If you know our products and are looking for technical information you are at the right place here.

     

    If you want to get an overview about our company, news and events please refer to www.saia-pcd.com.

     

     

  • System Catalogue 2017/2018

    A quick way to get an overview about our product range is to consult our system catalogue PLC, DDC, HMI, Web& IT

    • [26.0 MB]
      [26.0 MB]
      [26.0 MB]
      [26.0 MB]

Security Upgrade for PCD Controllers

New Firmwareversions offering improvements in IT-Security for PCD Controllers are ready to download. >> More Infos

Connection of PCD controllers directly to the Internet

Reduce the risk of potential intruders in automation systems. Take appropriate protective measures in your PCD control. >>More Infos

Last changes to this site

New Version Visi.Plus 1.7.104.37 available

Friday, 18. August 2017

A new version of Visi.Plus is available on the Support homepage. It has a lot of new features and improvements.


PCD Firmware 1.28.16 / 1.24.69 fix the Ethernet frame padding information leakage.

Wednesday, 09. August 2017

The Firmware  1.28.16 or 1.24.69 do fix the issue CVE-2017-9628 related to Ethernet frame padding information leakage.
To avoid any problems in relation to this leakage we do recommend strongly to update to the latest Firmware
1.28.16 / 1.24.69 or newer as mentioned on the security upgrade section on this web-page.

Impact of the CVE-2017-9628
IEEE 802 specifies that packets have a minimum size of 56 bytes.
The Ethernet driver is expected to fill the data field with octets of zero for padding when packets are less than 56 bytes.
Resident memory and other data are used for padding in some implementations that could cause information leakage.
This attack is passive; the attacker can only see data that the affected devices sent out as part of a packet.

Vulnerability overview of the CVE-2017-9628
The previous implementation of firmware allowed other data from a known area of memory to be used in this field and could exfiltrate or leak data.


New DDC Suite 2.7 Version 2.70.200

Wednesday, 12. July 2017

A new Version of the DDC Suite lib is available. This version corrects a bug for Alarming in BACnet Rev. 14, that can occur if Normally Closed is selected and Alarm Suppression via Event Inhibit is active.

You can find the version here.


COSinus Firmware 1.28.16 with BACnet Rev.14 support for PCD1.M2220-C15, PCD1.M2xx0, PCD2.M4x60, PCD3.Mxx60, PCD3.M6880, PCD3.T665/T666/T668 are available on the support homepage as well in the SBC PG5 update manager

Monday, 03. July 2017

This COSinus Firmware 1.28.16 do support the BACnet Rev. 14 and can be used on the following systems:

  • PCD1.M2220-C15
  • PCD1.M2xx0
  • PCD2.M4x60
  • PCD3.Mxx60
  • PCD3.M6880
  • PCD3.T665/T666/T668

The corresponding BACnet firmware 1.28.16 and the LonIP firmware 1.28.16 for this PCD's are also available on the support homepage.

The firmware are available on the support homepage as well in the SBC PG5 update manager.

This firmware should be used if BACnet Rev.14 is required in the application.
To use BACnet Rev.14 it’s necessary to use PG5 2.2.220 or newer.


COSinus maintenance Firmware 1.26.31 with BACnet Rev.9 support for PCD1.M2220-C15, PCD1.M2xx0, PCD2.M4x60, PCD3.Mxx60, PCD3.M6880 are available on the support homepage as well in the SBC PG5 update manager

Monday, 03. July 2017

This COSinus maintenance Firmware 1.26.31 do support the BACnet Rev. 9 and can be used on the following systems:

  • PCD1.M2220-C15
  • PCD1.M2xx0
  • PCD2.M4x60
  • PCD3.Mxx60
  • PCD3.M6880

The corresponding BACnet firmware 1.26.31 and the LonIP firmware 1.26.31 for this PCD's are also available on the support homepage.

The firmware are available on the support homepage as well in the SBC PG5 update manager.

This firmware should be used if BACnet Rev.9 is required in the application.


Displaying 1 to 5 of 90